HitechFibre Logo

HitechFibre Network Status

Real-time updates on the health of our network & services

HitechFibre Status
Dashboard

All systems are operational.

Parklands east
Fixed

Identified

1 month ago —

We’re aware of the current service interruption affecting some clients. The root cause has been identified as a power-related problem at the data centre, which is outside of HitechFibre’s network and control.

Fixed

1 month ago —

The earlier service interruption was caused by a power issue at the data centre, which was outside of our network.

We’re pleased to confirm that power has now been fully restored, and all affected services are coming back online and stabilising. Our team is actively monitoring the network to ensure continued stability.

If you are still experiencing any issues, please reboot your router and contact support if the problem persists.

Thank you for your patience and understanding.

1 month ago —

Parklands East – Line Fault Update We detected that the main backhaul link went offline. Traffic was automatically switched over to the backup link, and all connections are currently up and running. There may have been a brief interruption during the failover while the backhaul changed to the backup link.

Incident UUID 243fcffa-a642-4315-8831-e33d6d4eca46